BOL Magic 8 Ball

BOL Magic 8 Ball requires the Adobe Flash 8 plug-in of higher.

We have a non-flash version on the way, come back soon!

no flash?

BOL Magic 8 Ball

Ask a question out loud and "Shake" the magic ball by clicking on it. Your response will appear instantly.